I might have pissed off sct, lol.

Grog6

Moderator
Joined
Sep 22, 2023
Messages
1,554
Location
Harriman, TN
Vehicle Details
2x 1996 Cougars, 1997 Tbird 4.6's all.
Country flag
I tried my software today, and it says my dongle is invalid. Any Ideas? I'll call them Friday, but there's unlikely to be anyone to talk to until monday.
They gave me a phone number.
Seems like I sent them a pissy email because it wouldn't run under win 7, but I'm sure I used it after I upgraded.
Reckon they turned it off for spite?
 
I tried my software today, and it says my dongle is invalid. Any Ideas? I'll call them Friday, but there's unlikely to be anyone to talk to until monday.
They gave me a phone number.
Seems like I sent them a pissy email because it wouldn't run under win 7, but I'm sure I used it after I upgraded.
Reckon they turned it off for spite?

I am 100% certain that they don’t read emails

Calling tech support is the only reliable way to get in touch, but you’ll never get through when you’re put on infinite hold. I suggest calling in the morning, leave a message when it gives you the prompt in between the tropical island music and they’ll most likely call you back later in the day, that was my experience. If they don’t resolve it on the phone right away they’ll take you to a portal which they are much quicker to communicate from. The guy I talked to was actually helpful, I get the impression the company is operating with a skeleton crew these days
 
Sounds good. It seems to work, it just gives me the error when I try to update. I was going to see if they added the stuff to mbe2.
 
Sounds good. It seems to work, it just gives me the error when I try to update. I was going to see if they added the stuff to mbe2.

Download teamviewer from here ahead of time, they might use this for diagnosis while you're on the phone with them so having it ready to go will speed things up.


I was able to get stuff added to my MBE3, mostly CFSO parameters as well as 02 bias tables, nothing super useful tbh but stuff to play with nonetheless. To get them added they had me retake that same certification test we all had to take a few years ago after the EPA crackdown.
 
I'm 100% certain SCT does read emails. I recently worked through one in-depth issue with them via email, then TeamViewer. Currently working through a LS PCM issue with them via email as well. Calling is quicker of course, unless it's something that requires relaying over to their engineers, then you'll be waiting a call-back.
 
I'm 100% certain SCT does read emails. I recently worked through one in-depth issue with them via email, then TeamViewer. Currently working through a LS PCM issue with them via email as well. Calling is quicker of course, unless it's something that requires relaying over to their engineers, then you'll be waiting a call-back.

Probably because I politely whined about them not reading them lol I sent 4 over the course of two weeks back in September, I had a bear of a time getting through to them a few years ago via email trying to get EPA certification too, eventually someone asked on the pro racer forum and finally we got through.
 

Similar threads

Back
Top